Search Results (7 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2022-39823 1 Softing 2 Opc, Opc Ua C\+\+ Software Development Kit 2025-05-08 7.5 High
An issue was discovered in Softing OPC UA C++ SDK 5.66 through 6.x before 6.10. An OPC/UA browse request exceeding the server limit on continuation points may cause a use-after-free error
CVE-2022-37453 1 Softing 6 Edgeaggregator, Edgeconnector, Opc and 3 more 2025-05-08 7.5 High
An issue was discovered in Softing OPC UA C++ SDK before 6.10. A buffer overflow or an excess allocation happens due to unchecked array and matrix bounds in structure data types.
CVE-2021-32994 1 Softing 1 Opc Ua C\+\+ Software Development Kit 2025-04-16 7.5 High
Softing OPC UA C++ SDK (Software Development Kit) versions from 5.59 to 5.64 exported library functions don't properly validate received extension objects, which may allow an attacker to crash the software by sending a variety of specially crafted packets to access several unexpected memory locations.
CVE-2021-29661 1 Softing 1 Opc Toolbox 2024-11-21 5.4 Medium
Softing AG OPC Toolbox through 4.10.1.13035 allows /en/diag_values.html Stored XSS via the ITEMLISTVALUES##ITEMID parameter, resulting in JavaScript payload injection into the trace file. This payload will then be triggered every time an authenticated user browses the page containing it.
CVE-2021-29660 1 Softing 1 Opc Toolbox 2024-11-21 8.8 High
A Cross-Site Request Forgery (CSRF) vulnerability in en/cfg_setpwd.html in Softing AG OPC Toolbox through 4.10.1.13035 allows attackers to reset the administrative password by inducing the Administrator user to browse a URL controlled by an attacker.
CVE-2020-14524 1 Softing 1 Opc 2024-11-21 9.8 Critical
Softing Industrial Automation all versions prior to the latest build of version 4.47.0, The affected product is vulnerable to a heap-based buffer overflow, which may allow an attacker to remotely execute arbitrary code.
CVE-2020-14522 1 Softing 1 Opc 2024-11-21 7.5 High
Softing Industrial Automation all versions prior to the latest build of version 4.47.0, The affected product is vulnerable to uncontrolled resource consumption, which may allow an attacker to cause a denial-of-service condition.