Search Results (17 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2015-3297 1 Etherpad 1 Etherpad 2025-04-20 N/A
Directory traversal vulnerability in node/utils/Minify.js in Etherpad 1.1.1 through 1.5.2 allows remote attackers to read arbitrary files by leveraging replacement of backslashes with slashes in the path parameter of HTTP API requests.
CVE-2015-4085 1 Etherpad 1 Etherpad 2025-04-20 N/A
Directory traversal vulnerability in node/hooks/express/tests.js in Etherpad frontend tests before 1.6.1.
CVE-2021-34817 1 Etherpad 1 Etherpad 2024-11-21 6.1 Medium
A Cross-Site Scripting (XSS) issue in the chat component of Etherpad 1.8.13 allows remote attackers to inject arbitrary JavaScript or HTML by importing a crafted pad.
CVE-2021-34816 1 Etherpad 1 Etherpad 2024-11-21 7.2 High
An Argument Injection issue in the plugin management of Etherpad 1.8.13 allows privileged users to execute arbitrary code on the server by installing plugins from an attacker-controlled source.
CVE-2020-22785 1 Etherpad 1 Etherpad 2024-11-21 7.5 High
Etherpad < 1.8.3 is affected by a missing lock check which could cause a denial of service. Aggressively targeting random pad import endpoints with empty data would flatten all pads due to lack of rate limiting and missing ownership check.
CVE-2020-22783 1 Etherpad 1 Etherpad 2024-11-21 6.5 Medium
Etherpad <1.8.3 stored passwords used by users insecurely in the database and in log files. This affects every database backend supported by Etherpad.
CVE-2020-22782 1 Etherpad 1 Etherpad 2024-11-21 7.5 High
Etherpad < 1.8.3 is affected by a denial of service in the import functionality. Upload of binary file to the import endpoint would crash the instance.
CVE-2020-22781 1 Etherpad 1 Etherpad 2024-11-21 7.5 High
In Etherpad < 1.8.3, a specially crafted URI would raise an unhandled exception in the cache mechanism and cause a denial of service (crash the instance).
CVE-2019-18209 1 Etherpad 1 Etherpad 2024-11-21 6.1 Medium
templates/pad.html in Etherpad-Lite 1.7.5 has XSS when the browser does not encode the path of the URL, as demonstrated by Internet Explorer.
CVE-2018-9845 1 Etherpad 1 Etherpad Lite 2024-11-21 N/A
Etherpad Lite before 1.6.4 is exploitable for admin access.
CVE-2018-9327 1 Etherpad 1 Etherpad 2024-11-21 N/A
Etherpad 1.5.x and 1.6.x before 1.6.4 allows an attacker to execute arbitrary code on the server. The instance has to be configured to use a document database (DirtyDB, CouchDB, MongoDB, or RethinkDB).
CVE-2018-9326 1 Etherpad 1 Etherpad 2024-11-21 N/A
Etherpad 1.6.3 before 1.6.4 allows an attacker to execute arbitrary code.
CVE-2018-9325 1 Etherpad 1 Etherpad 2024-11-21 N/A
Etherpad 1.5.x and 1.6.x before 1.6.4 allows an attacker to export all the existing pads of an instance without knowledge of pad names.
CVE-2018-6835 1 Etherpad 1 Etherpad 2024-11-21 N/A
node/hooks/express/apicalls.js in Etherpad Lite before v1.6.3 mishandles JSONP, which allows remote attackers to bypass intended access restrictions.
CVE-2018-6834 1 Etherpad 1 Etherpad Lite 2024-11-21 N/A
static/js/pad_utils.js in Etherpad Lite before v1.6.3 has XSS via window.location.href.
CVE-2015-3309 1 Etherpad 1 Etherpad 2024-11-21 7.5 High
Directory traversal vulnerability in node/utils/Minify.js in Etherpad 1.1.2 through 1.5.4 allows remote attackers to read arbitrary files with permissions of the user running the service via a .. (dot dot) in the path parameter of HTTP API requests. NOTE: This vulnerability is due to an incomplete fix to CVE-2015-3297.
CVE-2015-2298 1 Etherpad 1 Etherpad 2024-11-21 N/A
node/utils/ExportEtherpad.js in Etherpad 1.5.x before 1.5.2 might allow remote attackers to obtain sensitive information by leveraging an improper substring check when exporting a padID.