Search Results (470 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2011-4290 1 Moodle 1 Moodle 2025-04-11 N/A
Multiple cross-site scripting (XSS) vulnerabilities in lib/weblib.php in Moodle 1.9.x before 1.9.12 allow remote attackers to inject arbitrary web script or HTML via vectors related to URL encoding.
CVE-2011-4289 1 Moodle 1 Moodle 2025-04-11 N/A
Moodle 2.0.x before 2.0.3 does not recognize the configuration setting that makes e-mail addresses visible only to course members, which allows remote authenticated users to obtain sensitive address information by reading a full profile page.
CVE-2011-4288 1 Moodle 1 Moodle 2025-04-11 N/A
Moodle 1.9.x before 1.9.12 and 2.0.x before 2.0.3 does not properly implement associations between teachers and groups, which allows remote authenticated users to read quiz reports of arbitrary students by leveraging the teacher role.
CVE-2021-36399 1 Moodle 1 Moodle 2025-03-07 5.4 Medium
In Moodle, ID numbers displayed in the quiz override screens required additional sanitizing to prevent a stored XSS risk.
CVE-2021-36398 1 Moodle 1 Moodle 2025-03-07 5.4 Medium
In moodle, ID numbers displayed in the web service token list required additional sanitizing to prevent a stored XSS risk.
CVE-2021-36397 1 Moodle 1 Moodle 2025-03-07 5.3 Medium
In Moodle, insufficient capability checks meant message deletions were not limited to the current user.
CVE-2021-36395 1 Moodle 1 Moodle 2025-03-07 7.5 High
In Moodle, the file repository's URL parsing required additional recursion handling to mitigate the risk of recursion denial of service.
CVE-2021-36403 1 Moodle 1 Moodle 2025-03-07 5.3 Medium
In Moodle, in some circumstances, email notifications of messages could have the link back to the original message hidden by HTML, which may pose a phishing risk.
CVE-2021-36402 1 Moodle 1 Moodle 2025-03-07 5.3 Medium
In Moodle, Users' names required additional sanitizing in the account confirmation email, to prevent a self-registration phishing risk.
CVE-2021-36401 1 Moodle 1 Moodle 2025-03-07 4.8 Medium
In Moodle, ID numbers exported in HTML data formats required additional sanitizing to prevent a local stored XSS risk.
CVE-2021-36400 1 Moodle 1 Moodle 2025-03-07 5.3 Medium
In Moodle, insufficient capability checks made it possible to remove other users' calendar URL subscriptions.
CVE-2021-36394 1 Moodle 1 Moodle 2025-03-06 9.8 Critical
In Moodle, a remote code execution risk was identified in the Shibboleth authentication plugin.
CVE-2021-36392 1 Moodle 1 Moodle 2025-03-06 9.8 Critical
In Moodle, an SQL injection risk was identified in the library fetching a user's enrolled courses.
CVE-2021-36393 1 Moodle 1 Moodle 2025-03-06 9.8 Critical
In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses.
CVE-2021-36396 1 Moodle 1 Moodle 2025-03-05 7.5 High
In Moodle, insufficient redirect handling made it possible to blindly bypass cURL blocked hosts/allowed ports restrictions, resulting in a blind SSRF risk.
CVE-2021-36568 2 Fedoraproject, Moodle 2 Fedora, Moodle 2024-11-21 5.4 Medium
In certain Moodle products after creating a course, it is possible to add in a arbitrary "Topic" a resource, in this case a "Database" with the type "Text" where its values "Field name" and "Field description" are vulnerable to Cross Site Scripting Stored(XSS). This affects Moodle 3.11 and Moodle 3.10.4 and Moodle 3.9.7.
CVE-2021-32478 1 Moodle 1 Moodle 2024-11-21 6.1 Medium
The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.
CVE-2021-32477 1 Moodle 1 Moodle 2024-11-21 4.3 Medium
The last time a user accessed the mobile app is displayed on their profile page, but should be restricted to users with the relevant capability (site administrators by default). Moodle versions 3.10 to 3.10.3 are affected.
CVE-2021-32476 1 Moodle 1 Moodle 2024-11-21 7.5 High
A denial-of-service risk was identified in the draft files area, due to it not respecting user file upload limits. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
CVE-2021-32475 1 Moodle 1 Moodle 2024-11-21 5.4 Medium
ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.